FAQ WinDevConsultez toutes les FAQ

Nombre d'auteurs : 3, nombre de questions : 71, dernière mise à jour : 25 novembre 2018  Ajouter une question

 

Cette FAQ ne prétend pas traiter de tous les trucs & astuces ou de tous les problèmes rencontrés par les utilisateurs de WinDev : elle a été créée via l'analyse des questions les plus fréquentes posées sur le forum de ce site, et sur les connaissances des différents rédacteurs. Nous espérons voir le nombre de questions/réponses augmenter régulièrement, pour couvrir le plus de thèmes possibles. Pour y participer, suivez le mode d'emploi donné dans la 2ème question !


SommaireConcepts, WLangage et environnementInterfaceDivers (3)
précédent sommaire suivant
 

Code windev : Sélectionner tout
1
2
3
4
5
6
7
8
9
10
11
gMondocument est un xlsDocument 
gMondocument = xlsOuvre("test.xls") 
  
FONCTION PositionnerOnglet(sNomOnglet est une chaîne) 
n est un entier 
  
POUR n = 1 A xlsNbFeuille(gMondocument) 
    xlsFeuilleEnCours(gMondocument,n) 
    SI sNomOnglet = gMondocument.NomFeuille ALORS RENVOYER Vrai 
FIN 
RENVOYER Faux

Mis à jour le 26 avril 2009 Emmanuel Lecoester

La touche ALT n'est pas une touche en tant que tel, c'est une touche système. Il faut placer le code :

Code windev : Sélectionner tout
ToucheEnfoncée(teAlt)
dans un traitement optionnel qui s'appelle WM_SYSKEYDOWN.

Mis à jour le 14 juillet 2009 Emmanuel Lecoester

La fonction ListeSelect est là pour ça :

Code windev : Sélectionner tout
1
2
3
4
5
6
7
8
9
  
i est un entier = 1 
LigneSelectionnee est un entier 
LigneSelectionnee = ListeSelect(Liste_Stock,1) 
TANTQUE LigneSelectionnee -1 
    Trace("La ligne n°"+ LigneSelectionnee +" est sélectionnée ->"+ Liste_Stock[LigneSelectionnee]) 
    i++ 
    LigneSelectionnee = ListeSelect(Liste_Stock,i) 
FIN

Mis à jour le 27 septembre 2009

Proposer une nouvelle réponse sur la FAQ

Ce n'est pas l'endroit pour poser des questions, allez plutôt sur le forum de la rubrique pour ça


Réponse à la question

Liens sous la question
précédent sommaire suivant
 

Les sources présentées sur cette page sont libres de droits et vous pouvez les utiliser à votre convenance. Par contre, la page de présentation constitue une œuvre intellectuelle protégée par les droits d'auteur. Copyright © 2019 Developpez Developpez LLC. Tous droits réservés Developpez LLC. Aucune reproduction, même partielle, ne peut être faite de ce site et de l'ensemble de son contenu : textes, documents et images sans l'autorisation expresse de Developpez LLC. Sinon vous encourez selon la loi jusqu'à trois ans de prison et jusqu'à 300 000 € de dommages et intérêts.

 
Contacter le responsable de la rubrique WinDev

Partenaire : Hébergement Web